當前位置: 首頁 » 股票知識 » 股票入門基礎知識 » 正文

飛狐四合一背離指標公式

放大字體  縮小字體 發布日期:2020-11-30  瀏覽次數:22

DIFF :=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA :=EMA(DIFF,9);
MACD :=2*(DIFF-DEA), COLORSTICK,LINETHICK2;
TRTR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
PDM:= SUM(IF(HD>0 AND HD>LD,HD,0),14);
MDM:= SUM(IF(LD>0 AND LD>HD,LD,0),14);
PDI:= PDM*100/TRTR;
MDI:= MDM*100/TRTR;
A1:=BARSLAST(ref(cross("macd.diff"(12,26,9),"macd.dea"(12,26,9)),1));
B1:=ref(c,A1+1)>c and ref("macd.diff"(12,26,9),A1+1)<"macd.diff"(12,26,9) and cross("macd.diff"(12,26,9),"macd.dea"(12,26,9));
A2:=BARSLAST(ref(cross("kdj.k"(9,3,3),"kdj.d"(9,3,3)),1));
B2:=ref(c,A2+1)>c and ref("kdj.k"(9,3,3),A2+1)<"kdj.k"(9,3,3) and cross("kdj.k"(9,3,3),"kdj.d"(9,3,3));
A3:=BARSLAST(ref(cross("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=ref(c,A3+1)>c and ref("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) and cross("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(ref(cross("macd.dea"(12,26,9),"macd.diff"(12,26,9)),1));
D1:=ref(c,C1+1)<c and ref("macd.diff"(12,26,9),C1+1)>"macd.diff"(12,26,9) and cross("macd.dea"(12,26,9),"macd.diff"(12,26,9));
C2:=BARSLAST(ref(cross("kdj.d"(9,3,3),"kdj.k"(9,3,3)),1));
D2:=ref(c,C2+1)<c and ref("kdj.k"(9,3,3),C2+1)>"kdj.k"(9,3,3) and cross("kdj.d"(9,3,3),"kdj.k"(9,3,3));
C3:=BARSLAST(ref(cross("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=ref(c,C3+1)<c and ref("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) and cross("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
C4:=BARSLAST(ref(cross(mdi,pdi),1));
D4:=ref(c,C+1)<c and ref(mdi,C4+1)>mdi and cross(mdi,pdi);
A4:=BARSLAST(ref(cross(PDI,MDI),1));
B4:=ref(c,A4+1)>c and ref(pdi,A4+1)<pdi and cross(pdi,mdi);
DMI底背:IF(B4>0,-0.1,0),COLOR0099FF,POINTDOT;
MACD底背:if(B1>0,-0.1,0),colorred,pointdot;
KDJ底背:if(B2>0,-0.1,0),colorff00ff,pointdot;
RSI底背:if(B3>0,-0.1,0),coloryellow,pointdot;
DMI頂背:IF(D4>0,0.1,0),COLORBLUE,POINTDOT;
MACD頂背:if(D1>0,0.1,0),color00ff00,pointdot;
KDJ頂背:if(D2>0,0.1,0),colorffcc66,pointdot;
RSI頂背:if(D3>0,0.1,0),colorwhote,pointdot;
STICKLINE(B1>0,-0.1,0,6,0),colorred;
STICKLINE(B2>0,-0.1,0,6,0),colorff00ff;
STICKLINE(B3>0,-0.1,0,6,0),coloryellow;
STICKLINE(d1>0,0.1,0,6,0),color00ff00;
STICKLINE(d2>0,0.1,0,6,0),colorffcc66;
STICKLINE(d3>0,0.1,0,6,0),colorwhite;
STICKLINE(B4>0,-0.1,0,6,0),color0099ff;
STICKLINE(D4>0,0.1,0,6,0),colorblue;


 
關鍵詞: 飛狐公式
 
[ 股票知識搜索 ]  [ 加入收藏 ]  [ 告訴好友 ]  [ 打印本文 ]  [ 違規舉報 ]  [ 關閉窗口 ]

 

 
推薦股票知識
點擊排行
 
(^ω^)MG华丽剧场首页 辽宁11选5直选遗漏 能交易的棋牌麻将游戏 福建彩票大奖一览表 149期三肖中特 吉林时时彩快三预测 北京赛车pk10将输改赢 吉林11选5开奖结果公告 青海11选5中奖查询 2021瑞波币价格预测 极速时时彩万能规律 东方6+1投注 mg视讯有假 体育彩票超级大乐透中奖规则 河北快乐扑克开奖结果 四川快乐12下午预测号 莱特币交易教程